Friday, July 02, 2010

Weather Photos

Last week, I took a drive to Canoe to meet my friend Graig for lunch and to get a windshield from him for my trike. On the way there I took some photos to show you why I drove my truck that day instead of my trike. I started out on the trike then after a short distance I turned around and came back home to (sadly) change vehicles. I was glad later that I had.




Earlier this spring, after a long time of drought, the city imposed very stiff water restrictions. Watering your yard only once per week, no water at all allowed in swimming pools. On the TV News, they interviewed a man who makes his living installing swimming pools and was afraid he would loose his business. Not only did we not get much rain last fall, but almost no snow at all over the winter, and were not seeing any rain this spring. Then the rains started!! This has been the wettest couple months I've seen in the Okanagan Valley in a very long time. The rains just don't seem to want to stop! Canada Day is usually a hot, dry day. Not this year! It was cool and cloudy with showers during the day and lots of rain in the evening. I hit some rain as I rode home from visiting Mom, never pleasant to ride a motorcycle in. I thought with hot, dry weather and the wind factor of riding, I'd need lots of wrinkle cream to protect my good looks (haha). As it turns out, I need something to protect my face from the sting as the nasty little rain drops hit me at highway speeds.

I just looked at the forecast for this week. I don't know why I bother, they always get it wrong, but occasionally I do look and see what the current guess is for upcoming weather. If they are right this time, summer could start next Tuesday.

.

3 comments:

Thom said...

Great photos my friend. I'm with you as well. Weathermen/women are rarely right it seems like LOL :)

Pamela said...

I've promised myself that my next road trip is going to be the Okanagan in Washington State. Now to convince my better half!

Anonymous said...

Hey, I can't view your site properly within Opera, I actually hope you look into fixing this.